The issue has been identified and we are working with our 3rd parties to restore access.
Posted Apr 27, 2025 - 11:18 BST
Investigating
We are currently investigating an issue affecting the inaccessibility of our analytic dashboards embedded in the platform, and also directly in Tableau.
Posted Apr 27, 2025 - 08:12 BST
This incident affected: Analytics Platform (Tableau).